Ticket #819 (closed doubt: fixed)

Opened 9 years ago

Last modified 9 years ago

Error message in BSR estimate

Reported by: imendez Owned by: josp
Priority: high Milestone: Mantainance
Component: BSR Version: 2.0.1
Severity: major Keywords:
Cc:

Description

Hi, BSR returns this error message:

[BSR.Parse] Parsing BSR file C:/users/imendez/bsd/entity/PrjBysForMeMoPr/data/output/Modelo_CEN02.ModeloEMU20091217_AllInputs_BSRHLM_y2009m12d17h16i44s03.00.bsr with 1625578 bytes
<E>
ERROR: [24] [BSR.Parse] Unexpected symbol not matching none of BSR (Bayesian Sparse Regression) declaration syntax options: 
Linear block variable declaration with initial values:
  my_linear_block_name <- number; 
Missing block variable declaration with initial values:
  my_linear_block_name ? <- number; 
Missing block variable declaration with prior info:
  my_linear_block_name ? ~ {Normal(nu,sigma^2)|TruncatedNormal(nu,sigma^2,minBound,maxBound)}; 
White noise distribution declaration with known homocedastic diagonal covariance:
  my_noise_block_name[length] ~ Normal(0,sigma^2);
White noise distribution declaration with known heterocedastic diagonal covariance:
  my_noise_block_name[length] ~ Normal(0,SetDiag([[sigma_1^2, sigma_2^2, ...]]));
White noise distribution declaration with unknown variance:
  my_noise_block_name[length] ~ Normal(0,my_sigma_block_name);
ARMA noise distribution declaration with unknown variance:
  my_noise_block_name[length] ~ Normal(0,my_sigma_block_name * ARMA.COV([[ARIMAStruct(period,ar,ma,dif),...]]));
Linear regressing equation:
  {number|?} == my_noise_block_name[index] {+|-}{{number|missing_block_name}*}my_linear_block_name {+|-}{{number|missing_block_name}*}my_linear_block_name  ... ;
Linear constraining inequation
  number {<=|>=} {+|-}{{number}*}my_linear_block_name {+|-}{{number}*}my_linear_block_name ... ;

 File:'C:/users/imendez/bsd/entity/PrjBysForMeMoPr/data/output/Modelo_CEN02.ModeloEMU20091217_AllInputs_BSRHLM_y2009m12d17h16i44s03.00.bsr' Line:113 Col:83
Puede ver un ejemplo de la sintaxis de BSR en http://cvs.tol-project.org/viewcvs.cgi/*checkout*/tol/stdlib/math/stat/models/bayesian/bysMcmc/test_01/parse.bsr</E>

[Call stack]
  [3] Set StdLib::BysMcmc::Bsr::Gibbs::EstimAscii (Text ascii_, Set nonLinFilter, NameBlock config, NameBlock notifier)
  [2] Set StdLib::BysMcmc::Bsr::Gibbs::EstimAndNotify (Anything modelDef, NameBlock config, NameBlock notifier)
  [1] Set StdLib::BysMcmc::Bsr::DynHlm::DBApi::Estim (Text dbName, Text model, Text session, Text resultRootPath, NameBlock seriesHandler, NameBlock config_)
<E>

However, the file seems to be correct at the indicated point (Line:113 Col:83). I attach .log and .bsr files.

Regards.

Attachments

Ticket#819.7z (156.3 kB) - added by imendez 9 years ago.

Change History

Changed 9 years ago by imendez

Changed 9 years ago by vdebuen

  • status changed from new to closed
  • resolution set to fixed

En alguna parte parece que hay una limitación de 100 caracteres para los identificadores por lo que está cortando los nombres. En esa línea concreta aparece unidentificador que acaba en : porque ha sido recortado.
Ahora mismo no sé exactamente dónde se pone ese límite pero a mí no me parece nada malo que lo haya pues un identificador de 100 caracteres ya es algo absolutamente ilegible para un humano medio.

Changed 9 years ago by josp

  • version changed from 1.1.7 to 2.0.1
  • component changed from Database to BSR
  • milestone set to Manteinance
Note: See TracTickets for help on using tickets.