Ticket #1895 (new defect)

Opened 3 years ago

Last modified 3 years ago

recompilar paquetes con CentOS 6

Reported by: josp Owned by: vdebuen
Priority: highest Milestone: Mantainance
Component: Packages Version: head
Severity: blocker Keywords:
Cc: acerdan, pgea

Description

Los paquetes de linux deben recompilarse con una versión de gcc antigua para asegurar su compatibilidad en la mayor cantidad de Linux. Usaremos un CentOS 6 que tiene un gcc 4.4.

La situación actual es que los apquetes disponibles no son usables en servidores linux en producción que usan versiones no actuales de las distribuciones de linux.

También hay que asegurar que todas las dependencias de libs externasl no sistema sean incluidas con el paquete ya sea con enlace estático o precarga de la .so

Change History

Changed 3 years ago by josp

(In [7028]) refs #1895, recompilación de TolIpopt para Linux 64

Changed 3 years ago by josp

(In [7030]) refs #1895, compilación de TolExcel 64 bits con gcc 4.4

Changed 3 years ago by josp

(In [7031]) refs #1895, compilación de MatQuery 64 bits con gcc 4.4

Changed 3 years ago by josp

(In [7032]) refs #1895, compilación de NonLinGloOpt 64 bits con gcc 4.4, se corrige un error en la conversión de pointer a BDat

Changed 3 years ago by josp

(In [7033]) refs #1895, compilación de BysSampler 64 bits con gcc 4.4

Changed 3 years ago by josp

(In [7034]) refs #1895, compilación de iVariableChange 64 bits con gcc 4.4

Changed 3 years ago by josp

(In [7035]) refs #1895, compilación de AlgLib 64 bits con gcc 4.4

Changed 3 years ago by josp

(In [7036]) refs #1895, compilación de TolGsl 64 bits con gcc 4.4

Changed 3 years ago by josp

(In [7037]) refs #1895, compilación de TolRInside 64 bits con gcc 4.4

Note: See TracTickets for help on using tickets.